Quoi de neuf dans Ubuntu 20.04 LTS « Focal Fossa » ?

thumbnail-news-ubuntu

Ubuntu 20.04 LTS « Focal Fossa » est disponible en version finale de puis le 23 avril 2020. Au programme plus de rapidité, de fluidité, et plusieurs autres changements et améliorations. Faisons le tour des principales nouveautés.

Nom de code de Ubuntu 20.04 : Focal Fossa

Le nom de code Ubuntu 20.04 est Focal Fossa. Le Fossa est un mammifère carnivore féliforme (de la famille des félins) que l’on trouve sur l’île de Madagascar. Adulte, il mesure 70 à 80 cm.

Et il est parfois comparé au puma.

Ubuntu 20.04 LTS : un support jusqu’en Avril 2025

Tous les 6 mois, Canonical sort une nouvelle version de Ubuntu. Par contre, celles qui ont un support à long terme (LTS) de 5 ans ne sortent que tous les 2 ans. Les versions entre les deux n’ont qu’un support de 9 mois.

frise chronologique version ubuntu
source : Wikipédia

Ainsi, deux ans après Ubuntu 18.04 « Bionic Beaver », Ubuntu 20.04 est la nouvelle version LTS de la distribution. Son support sera donc assuré pour le grand public jusqu’en Avril 2025.

Les principales nouveautés de Ubuntu 20.04 LTS

Pas de version 32 bits

Depuis Ubuntu 18.04, Canonical ne proposait plus d’ISO d’installation 32 Bits de l’ISO pour la distribution. Mais, certaines déclinaisons (Xubuntu, Lubuntu,…) proposaient tout de même cette image.

Avec Ubuntu 20.04, c’est fini, aucune variante ne proposera d’image 32 bits. En effet, comme annoncé il y a quelques temps, Canonical abandonne progressivement le support des paquets 32 bits sur ses dépôts. Et même si quelques rares paquets 32 bits sont conservés, ils permettent pas de faire une installation 32 bits…

Donc si votre ordinateur est 32 bits, tant que Ubuntu 18.04 reste supportée (jusqu’en Avril 2023) et vous pouvez rester sur cette version. Mais après Avril 2023, il faudra vous tourner vers une autre distribution. Par exemple Debian qui support toujours le 32 bits…

Un noyau Linux 5.4

Ubuntu 20.04 est livrée avec un noyau Linux en version 5.4. Ce noyau est disponible depuis le Novembre 2019. Parmi les améliorations qu’il apporte, je note :

  • l’amélioration de la sécurité avec par exemple l’ajout dans le module de sécurité d’une fonctionnalité de verrouillage du noyau. Mais elle n’est pas active par défaut.
  • la prise en charge de nouveaux GPU AMD (Navi 12 et 14) et Intel (Tiger Lake)
  • l’ajout de support de nouveaux système de fichiers (ExFAT) et l’amélioration d’autres comme le ZFS.

Pour plus de détails, rendez-vous sur la page des notes de version du noyau Linux 5.4 (en anglais).

Le support ZFS dans Ubuntu 20.04

Dans Ubuntu 19.10, Canonical introduisait la possibilité d’utilisé ce système de fichier de manière expérimentale. Dans Ubuntu 20.04, il est à nouveau proposé avec des améliorations, mais reste toujours expérimental.

Le support de WireGuard inclus dans le noyau de Ubuntu 20.04

WireGuard est un protocole libre et récent pour les VPN. Plus rapide, plus léger et plus sécurisé, il devrait remplacer peu à peu le vieillissant protocole OpenVPN. D’ailleurs, son support vient d’être ajouté au récent noyau Linux 5.6, sorti le 30 mars 2020.

Aussi Canonical a décidé de rétro-porter sa prise en charge dans le noyau de sa distribution.

Un démarrage plus rapide

Déjà introduit dans Ubuntu 19.10, Ubuntu 20.04 conserve l’algorithme LZ4, pour compresser le noyau et réduite le temps de démarrage de la distribution.

Gnome 3.36 avec des améliorations du thème Yaru

Avec Ubuntu 18.04, Canonical abandonna son environnement maison Unity pour repasser à l’environnement Gnome.

Et pour Ubuntu 20.04, ça sera la version Gnome 3.36, sorti le 11 mars 2020. Parmi les nouveautés de cette version, notons :

  • un nouvel écran de connexion
  • un nouveau menu Fermer la session / Éteindre
  • un panneau de configuration repensé
  • les dossiers d’applications adoptant un nouveau design et pouvant être renommés
  • des performances améliorées
  • et surtout une impression d’une meilleure fluidité de l’interface…

Pour plus de détails, lisez cet article sur les nouveautés de Gnome 3.36 .

Aussi, GDM (GNOME Display Manager qui gère la fenêtre de connexion) mémorise l’état du pavé numérique une fois validé une première fois. Donc, plus de besoins de modifier sa configuration pour avoir le Verr Num actif au démarrage.

De plus, le thème Yaru de Ubuntu connaît plusieurs évolutions visuelles :

Puis la bascule vers les déclinaison du thème en Light ou Dark plus facile. Pour cela, rendez directement dans le panneau des Paramètres système puis dans le nouvel onglet Apparence qui remplace l’onglet Dock :

Paramètres Apparence

Et, voici le fond d’écran officiel de Ubuntu 20.04.

font écran officiel ubuntu 20.04

Et du coté des applications

Tout d’abord, bonne nouvelle, l’application Amazon, que personnellement je désinstallais systématiquement, disparaît…

Le Snap Store remplace le Ubuntu Software

Puis autre changement majeure, le Snap Store remplace le Ubuntu software. Il reste basé sur le GNOME Software, mais est proposé au format snap.

snap store

Canonical tient vraiment à imposer son format snap en remplacement des bons vieux paquets deb. Il met en avant qu’ainsi vos paquets seront toujours maintenus à jour dans leur version les plus récentes contrairement au dépôts officiels où ils n’évoluent quasi plus une fois la distribution sortie.

Toutefois, il est toujours possible d’installer des paquets deb depuis les dépôts officiels ou des PPA ou encore des paquets flatpak (une bonne alternative au format snap) avec des commandes dans un terminal (sudo apt install ou flatpak install).

Par contre, les utilitaires (calculatrice, la table des caractères, …) installés par défaut au format snap depuis Ubuntu 18.04 rebasculent vers des paquets Deb. Et oui, ces dernières au format snap mettez plus de temps pour se lancer…

Plus de support pour Python 2. Vive Python 3 !

Python est un langage de programmation utilisé par plusieurs logiciels entre autre sous Linux. Aujourd’hui, la version utilisée est la 3.x (première version de cette branche en 2008). Quand à la version 2, elle date de 2000.

La fin de support de Python 2, signifie que certains logiciels (anciens) non ré-écrits en Python 3 ne marcheront plus sous Ubuntu 20.04…

Les applications populaires dans leur dernière version sur les dépôts

Sinon, sur les dépôts, la plupart de logiciels majeurs sont disponible dans leur version la plus récente au moment de la sortie de la distribution :

  • LibreOffice 6.4
  • Firefox 74.0
  • Thunderbird 68.6.0
  • Gimp 2.10.18

Des variantes avec les dernières versions de leur environnement

La plupart des variantes officielles adoptent pour leur environnement la dernière version disponible de ce dernier. Ainsi :

Et la version serveur connaît de nombreuses améliorations. Je note le passage à :

  • PHP 7.4
  • Ruby 2.7
  • Bind 9.16
  • la prise en charge de U2F (norme pour l’authentification à deux facteurs) avec OpenSSH
  • Samba 4.11

Installer Ubuntu 20.04

Voici le lien vers mon tutoriel pour installer Ubuntu 20.04 LTS.

Mettre à jour vers Ubuntu 20.04

Voici le lien vers mon tutoriel pour mettre à niveau vers Ubuntu 20.04 LTS.

Pour aller plus loin

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

53 Commentaires

  1. Bonjour,
    je viens d’installer ubuntu 20.04 et il m’est impossible d’installer pykaraoke et photoprint. Par la logithèque les dépendances ne sont pas satisfaites et via la console les paquets sont introuvables ; alors que je n’ai aucun problème pour l’installation des paquets nativement présents dans les dépots.
    Pourriez-vous m’éclairer.
    Merci d’avance.

    1. Bonjour Patrick,

      Je ne connais pas ces deux applications, mais visiblement, la dernière version de pykaraoke date du 26/08/2011 et de photoprint du 29/05/2010. Et ces deux applications semblent ne plus être supportées.

      Bien que présent sur les dépôts de Ubuntu 18.04, elles ont été retirées des dépôts pour Ubuntu 20.04 :
      https://packages.ubuntu.com/search?suite=focal&section=all&arch=any&keywords=pykaraoke
      https://packages.ubuntu.com/search?suite=focal&searchon=names&keywords=photoprint

      Ce qui explique pourquoi vous ne pouvez pas les installer. Il peut y avoir plusieurs raisons à cela comme des dépendances nécessaires dans des versions obsolètes et plus supporté. Beaucoup d’application en Python 2 on été retirée du fait de sa fin de support (pykaraoke semble écrit en Python…)

      Aussi, peut-être devriez-vous trouver des équivalents encore supportés.

      Cordialement

  2. et puis,

    jean-michel@jeanmichel-X550CA:~$ systemd-analyze critical-chain
    The time when unit became active or started is printed after the « @ » character.
    The time the unit took to start is printed after the « + » character.

    graphical.target @1min 45.465s
    └─multi-user.target @1min 45.465s
      └─snap.network-manager.networkmanager.service @1min 37.284s +108ms
        └─network.target @1min 10.311s
          └─NetworkManager.service @1min 1.993s +8.316s
            └─dbus.service @1min 1.982s
              └─basic.target @1min 1.798s
                └─sockets.target @1min 1.798s
                  └─snapd.socket @1min 1.795s +2ms
                    └─sysinit.target @1min 1.544s
                      └─systemd-timesyncd.service @1min 669ms +874ms
                        └─systemd-tmpfiles-setup.service @59.857s +768ms
                          └─systemd-journal-flush.service @8.078s +51.777s
                            └─systemd-journald.service @6.791s +1.280s
                              └─systemd-journald.socket @6.782s
                                └─-.mount @6.754s
                                  └─system.slice @6.754s
                                    └─-.slice @6.754s
    jean-michel@jeanmichel-X550CA:~$
    1. Il semble qu’une des raisons soit l’écriture des logs qui prend du temps (systemd-journal-flush.service). Votre fichier log est peut-être trop gros…

      Que vous renvoie :

      journalctl --disk-usage
  3. Bonjour, depuis la mise à jour ubuntu 20.04 mon ordi met 1 minute 57 seconde à démmarer. Quelqu’un peut il m’aider à résoudre ce problème?
    Merci pour votre aide
    Jean-Mi29

      1. jean-michel@jeanmichel-X550CA:~$ systemd-analyze blame
        
        51.777s systemd-journal-flush.service                                          >
        33.140s plymouth-quit-wait.service                                             >
        30.862s dev-sda2.device                                                        >
        17.687s snapd.service                                                          >
        17.685s dev-loop20.device                                                      >
        17.228s dev-loop21.device                                                      >
        16.824s dev-loop22.device                                                      >
        16.675s dev-loop11.device                                                      >
        16.669s dev-loop18.device                                                      >
        16.585s dev-loop15.device                                                      >
        16.583s dev-loop12.device                                                      >
        16.583s dev-loop17.device                                                      >
        16.580s dev-loop19.device                                                      >
        15.189s dev-loop1.device                                                       >
        15.170s dev-loop7.device                                                       >
        14.965s dev-loop0.device                                                       >
        14.581s dev-loop2.device                                                       >
        14.471s dev-loop8.device                                                       >
        14.240s dev-loop13.device                                                      >
        13.781s accounts-daemon.service                                                >
        13.686s dev-loop16.device                                                      >
        13.585s dev-loop14.device                                                      >
        13.439s dev-loop6.device                                                       >
        13.073s dev-loop4.device                                                       >
        12.972s dev-loop10.device                                                      >
        12.597s snapd.apparmor.service                                                 >
        12.048s dev-loop9.device                                                       >
        12.014s dev-loop3.device                                                       >
        11.670s udisks2.service                                                        >
        11.609s dev-loop5.device                                                       >
        10.821s networking.service                                                     >
        10.534s apport-autoreport.service                                              >
        10.446s grub-initrd-fallback.service                                           >
        10.307s gpu-manager.service                                                    >
         9.916s networkd-dispatcher.service                                            >
         8.573s NetworkManager-wait-online.service                                     >
         8.543s systemd-udevd.service                                                  >
         8.368s avahi-daemon.service                                                   >
         8.316s NetworkManager.service                                                 >
         7.569s polkit.service                                                         >
         7.465s grub-common.service                                                    >
         7.415s switcheroo-control.service                                             >
         7.405s thermald.service                                                       >
         7.395s systemd-logind.service                                                 >
         7.373s wpa_supplicant.service                                                 >
         5.075s ModemManager.service                                                   >
         4.573s systemd-modules-load.service                                           >
         4.447s systemd-resolved.service                                               >
         3.713s rsyslog.service                                                        >
         3.441s secureboot-db.service                                                  >
         3.371s apparmor.service                                                       >
         2.610s systemd-sysctl.service                                                 >
         2.492s systemd-sysusers.service                                               >
         2.139s snap-core-8935.mount                                                   >
         2.051s snap-core-9066.mount                                                   >
         2.016s gdm.service                                                            >
         1.993s alsa-restore.service                                                   >
         1.963s openvpn.service                                                        >
         1.950s snap-core18-1705.mount                                                 >
         1.912s systemd-user-sessions.service                                          >
         1.894s snap-core18-1754.mount                                                 >
         1.768s systemd-tmpfiles-setup-dev.service                                     >
         1.739s rc.local.service                                                       >
         1.684s snap-gnome\x2d3\x2d26\x2d1604-97.mount                                 >
         1.578s snap-gnome\x2d3\x2d26\x2d1604-98.mount                                 >
         1.500s systemd-fsck@dev-disk-by\x2duuid-98E8\x2d2EAA.service                  >
         1.464s binfmt-support.service                                                 >
         1.333s systemd-backlight@backlight:intel_backlight.service                    >
         1.320s tlp.service                                                            >
         1.319s snap-gnome\x2d3\x2d28\x2d1804-110.mount                                >
         1.305s snap-gnome\x2d3\x2d28\x2d1804-116.mount                                >
         1.280s systemd-journald.service                                               >
         1.181s systemd-udev-trigger.service                                           >
         1.154s snap-gnome\x2d3\x2d34\x2d1804-33.mount                                 >
         1.132s lm-sensors.service                                                     >
         1.077s systemd-random-seed.service                                            >
         1.048s apport.service                                                         >
         1.042s upower.service                                                         >
          984ms snap-gnome\x2dsystem\x2dmonitor-135.mount                              >
          949ms snap-gnome\x2dsystem\x2dmonitor-145.mount                              >
          927ms e2scrub_reap.service                                                   >
          902ms colord.service                                                         >
          881ms qemu-kvm.service                                                       >
          874ms systemd-timesyncd.service                                              >
          768ms systemd-tmpfiles-setup.service                                         >
          740ms snap-gtk\x2dcommon\x2dthemes-1502.mount                                >
          662ms snap-gtk\x2dcommon\x2dthemes-1506.mount                                >
          594ms snap-mosquitto-249.mount                                               >
          584ms keyboard-setup.service                                                 >
          582ms snap-mosquitto-269.mount                                               >
          571ms ifupdown-pre.service                                                   >
          569ms snap-network\x2dmanager-379.mount                                      >
          567ms user@1000.service                                                      >
          522ms snap-network\x2dmanager-514.mount                                      >
          503ms dev-disk-by\x2duuid-55df8391\x2dce84\x2d41b3\x2da8e4\x2d5a1aacb47158.sw>
          427ms systemd-tmpfiles-clean.service                                         >
          426ms snap-snap\x2dstore-433.mount                                           >
          415ms snap-snap\x2dstore-454.mount                                           >
          372ms systemd-remount-fs.service                                             >
          342ms dev-hugepages.mount                                                    >
          341ms dev-mqueue.mount                                                       >
          339ms sys-kernel-debug.mount                                                 >
          338ms sys-kernel-tracing.mount                                               >
          333ms kmod-static-nodes.service                                              >
          290ms pppd-dns.service                                                       >
          286ms ufw.service                                                            >
          282ms snap-vlc-1620.mount                                                    >
          266ms systemd-update-utmp-runlevel.service                                   >
          254ms snap-wifi\x2dap-355.mount                                              >
          247ms snap-vlc-1397.mount                                                    >
          227ms proc-sys-fs-binfmt_misc.mount                                          >
          215ms systemd-update-utmp.service                                            >
          189ms snap-wifi\x2dap-303.mount                                              >
          186ms console-setup.service                                                  >
          170ms dns-clean.service                                                      >
          152ms boot-efi.mount                                                         >
          147ms hddtemp.service                                                        >
          143ms user-runtime-dir@1000.service                                          >
          134ms ureadahead-stop.service                                                >
          108ms snap.network-manager.networkmanager.service                            >
           75ms kerneloops.service                                                     >
           74ms snapd.seeded.service                                                   >
           67ms resolvconf-pull-resolved.service                                       >
           63ms setvtrgb.service                                                       >
           60ms plymouth-read-write.service                                            >
           18ms plymouth-start.service                                                 >
           13ms rtkit-daemon.service                                                   >
            7ms sys-fs-fuse-connections.mount                                          >
            5ms sys-kernel-config.mount                                                >
            2ms snapd.socket                                                           >
  4. Bonjour,
    Je suis preneuse d’une idée pour faire fonctionner sans problème mon imprimante multifonction HP4520 sous ubuntu 20.04.
    J’ai cru avoir trouver ce matin via ce lien : https://forum.ubuntu-fr.org/viewtopic.php?id=2052359
    Elle a fonctionné une fois correctement mais stop plus rien.
    De plus je n’ai plus accès au disque dur de la freebox.
    C’est très étrange et très embêtant
    Merci d’avance pour vos conseils avisés.

    1. Bonjour Marie,

      Pour l’accès aux partages sur une Freebox (fichiers et imprimantes), avec Ubuntu 20.04, il peut y avoir en effet un problème. Vous trouverez ici des détails pour résoudre le problème.

      Sinon, en résumer, installez le paquet smbclient si ça n’est pas déjà fait.

      sudo apt install smbclient

      Puis, il faut modifier le fichier smb.conf et ajouter le support de l’ancien protocole NT1 qu’utilise la Freebox pour le partage réseau. En ligne de commande ça donne :

      sudo nano /etc/samba/smb.conf

      Puis, en dessous de [global] ajoutez les lignes suivantes :

      [global]
      ; max protocol = SMB2
      client min protocol = NT1

      Cordialement.

      1. merci beaucoup
        je vais essayer ça
        j’ai vu déjà que smbclient n’était pas installé
        j’attends de voir pour la suite de vos opérations
        encore merci

        Pour l’imprimante j’ai déjà changé le branchement et du coup elle imprime c’est déjà bien
        par contre gràce à ça le scan se lance (on progresse )
        mais je ne peux pas enregistrer l’image obtenue car xsane se ferme avant !!

      2. j’ai l’impression que le terminal ne veut pas enregistrer la modif
        y a t-il une manip spéciale à faire pour enregistrer cela en fermant le terminal ?
        merci encore

      3. en fait voilà ce que j’obtiens dans le terminal
        pour smbclient -L 192.168.1.254 -U%
        Connection to 192.168.1.254 failed (Error NT_STATUS_HOST_UNREACHABLE)

        puis pour testparm -v | grep protocol
        Load smb config files from /etc/samba/smb.conf
        Loaded services file OK.
        WARNING: The ‘netbios name’ is too long (max. 15 chars).

        Server role: ROLE_STANDALONE

        Press enter to see a dump of your service definitions

        client ipc max protocol = default
        client ipc min protocol = default
        client max protocol = default
        client min protocol = SMB2_02
        server max protocol = SMB3
        server min protocol = SMB2_02

      4. Votre retour console indique en effet que vous n’avez pas du bien enregistrer la modification.

        Avec nano pour enregistrer les modifications dans le fichier, faites CTRL + o ou CTRL + s, puis pour quitter CTRL + X.

        Cordialement

      5. merciiiiiiii
        ça c’est bien enregistré et j’ai à nouveau accés aux fichiers de la freebox
        merci beaucoup pour votre aide
        je vous souhaite une bonne journée

        Espérons que je vais trouver une solution pour faire fonctionner xsane jusqu’au bout de l’enregistrement (je suis prof et je l’utilise tous les jours ou presque 😉 )
        encore merci

      6. Je vais regarder en début de semaine comment marche xsane avec Ubuntu 20.04. Je vous tiens au courant.

        Ubuntu 20.04 est encore « jeune ». En principe, pour les novices, je conseille de ne passer à une nouvelle version LTS que lorsque sa version XX.XX.1 sort (habituellement 3 mois après) car elle est beaucoup plus stable et les développeurs auront sorti des nouvelles versions de leur paquets corrigeant les bugs de démarrage.

        Vous etes sur Ubuntu ou une variante officielle (Xubuntu, Kubuntu,…) ?

        Bonne fin de we.

        Cordialement

      7. je suis sous ubuntu
        D’habitude j’attends toujours avant de faire la mise à niveau …
        Mais là sans doute pas assez 😉
        merci encore pour votre aide

      8. Bonjour Marie,

        J’ai fait des essais de Xsane avec Ubuntu 20.04 et une Imprimante/scanner Canon. Résultat, branché directement sur mon ordi via USB, pas de soucis. Par le réseau, parfois le scan est partiel du à des pertes de communication.

        Sinon j’ai testé le numériseur de documents inclus de base dans Ubuntu. Il est beaucoup plus simple et sobre, mais il marche à chaque fois. Du moins chez moi…

        Cordialement

      9. merci pour votre aide
        L’imprimante ne marche pas branchée en usb c’est définitif (pour l’instant)
        Mais je l’ai connecté à ma freebox en wifi et tout marche à merveille.
        Donc je n’ai plus de problème.
        Encore merci pour votre disponibilité

  5. Bonjour
    Si quelqu’un à une idée pour faire fonctionner le scanner d’une HP3055A je suis preneur.
    ll me trouve bien mon scanner mais c’est galère.
    Hplip-3.20.5 ne s’installe pas à cause d’un problème de dépendance Python qui est pourtant installé

    1. Bonjour,

      Personnellement, je n’ai pas d’expérience avec les scanners HP. Qu’entendez-vous par « c’est galère » ? Et quelle message d’erreur avez-vous pour l’installation de Hplip ?

      Cordialement

      1. c’est un problème de dépendance avec les paquets Python5 qu’ils n’arrivent pas à
        pyqt5 gui_qt5 c’est ce paquet qu’il n’arrive pas à installer c’est le seul qui est indispensable.

        avec la version précédente 19.04 aucun soucis la version hplip-20.3 est incompatible avec la 20.04. et la version, hplip20.5 pose un soucis je suis en train de réécrire le une partie du script mais cça prend du temps
        voila

      2. Bonjour Robert,

        J’ai testé l’installation de HPlip (téléchargé directement sur le site de HP) sur ma Ubuntu 20.04 et chez moi aucun problème, aucune erreur de dépendances non satisfaites… Mais pas pu tester le reste car j’ai pas de scanner/imprimante HP.

        Cordialement

    2. Très bien merci pour ta réponse c’est très bizarre j’ai moi aussi téléchargé a 3.20..5 chez hp et je ne suis pas novice dans le domaine étant informaticien depuis très longtemps.
      Je vais revoir mon installation ubuntu (heureusement j’ai une autre machine qui me sert pour les tests des paquets Debian avant).
      Xsane que j’utilise depuis longtemps ne me trouve pas mon scanner alors qu’en regardant ubuntu le vois bien.
      peut être lié à mon modèle d’imprimante qui n’apparaît pas dans les imprimantes prise en charge

  6. Salut a tous. Pour ma part cette distro est une pure catastrophe comme je n en n ai jamais vu chez linux!!!! Perte de données personnelles…uuid qui se modifie tout seule commande sudo devenue inapte….tracker miner ne s est pas amélioré pour l indexation et je dirai même qu il est pire…. Un démarrage lent et pareillement pour des applis y compris libre Office qui en plus de figé parfois….c est bien la première fois où je suis déçu par une distri linux au point de me dire que ça serai pas pire de repartir chez Windows vu le déluge….

    1. Bonjour Maton,

      Merci pour ce retour d’expérience. Pour ma part, je ne fais pas le même constat. Si vous avez fait une mise à niveau depuis 18.04 et d’autre avant, peut-être devriez-vous re-tester à partir d’une nouvelle installation…

      Cordialement

  7. bonjour
    j’ai installé la,version 20.04. et je n’ai plus accès à mon lecteur eid (carte identité). comment faire pour le récupérer.
    merci bien à vous.

    1. Bonjour,

      Je n’ai pas d’expérience sur ce type d’équipement, mais avez-vous essayé d’installer les drivers puis les paquets eid-viewer et eid-mw. (sudo apt install eid-viewer et sudo apt install eid-mw)
      Par contre, il semble ne pas encore y avoir une version de ces dernier pour Ubuntu 20.04 LTS dont la sortie est encore récente. Toutefois, vous pouvez essayer la version pour Ubuntu 19.10…

      Cordialement

  8. Bonjour
    j’ai migré de Ubuntu 18.04 vers 20.04, puis j’ai réinstallé VLC et Jdownloder.
    Mais la police d’écriture est devenue minuscule.
    Dans les préférences de ces applis, il n’y a pas moyen d’agrandir.
    et dans les préférences d’apparence du système les réglages ne jouent pas sur la police de VLC et Jdownloader.
    Après des recherches le problème serait lié à la librairie QT, mais je ne sais pas laquelle installer pour quelle soit compatible.
    Avez vous une solution avant que je devienne aveugle ?
    merci de votre aide.

    1. Bonjour Gege,

      Avez-vous installé VLC et JDownloader depuis le Snap Store (Ubuntu Software) ? Dans ce cas, les applications sont au format Snap ce qui explique qu’elles ne tiennent pas compte des paramêtres d’affichage système.

      Aussi, je vous recommande à la place d’utiliser le paquet Deb de VLC et l’installeur depuis le site de JDownloader. Pour les installer ouvrez un terminal (Ctrl + Alt + T). Alors pour installer VLC, faites :

      sudo apt install vlc

      et pour JDownloader, d’abord télécharger le avec :

      wget http://installer.jdownloader.org/JD2Setup_x64.sh

      puis pour l’installer, faites :

      sh JD2Setup_x64.sh

      un fois l’installation finie, vous pouvez supprimer l’installeur avec :

      rm JD2Setup_x64.sh

      Cordialement

      1. Bonsoir
        Merci pour la réponse rapide. J’ai installé les 2 depuis les pages officielles des 2 applis.
        C’est bon pour VLC, mais pas pour Jdownloader.
        A la fin de l’installation au lancement une fenêtre s’ouvre disant « trail is not support », puis s’ouvre normalement mais avec une écriture minuscule comme avant.
        Une autre piste, si vous avez, elle serait la bien venue.

      2. Je vous ai indiqué ma démarche du début, pour installer je suis passé par le site de VLC et Jdowloader.
        Pour corriger, j’ai fait ce que vous m’avez indiqué.
        Cela à fonctionné pour vlc et c’est super, mais pas pour Jdownloader.
        Cordialement

      3. Bonjour,

        L’erreur « trail is not support » vient du fait que l’ajout de l’icône dans la la zone de notification n’est pas possible, certainement du à une incompatibilité avec Gnome 3.36.
        Je viens de comparer la version Snap (depuis le Snap Store) et la version installer manuellement, en effet, je n’ai pas de différence. Mais j’ai la même chose sur Ubuntu 18.04…
        Sinon pour grossir les polices de caractères dans JDownloader, allez dans les Settings > Advanced settings > LAFSettings.fontscalefactor et augmentez la valeur. Puis redémarrer JDownloader pour appliquer le nouveau paramètre.

        Cordialement

      4. C’est nickel ça marche
        merci beaucoup, je le note dans mes tablettes !
        Bonne continuation

  9. Bonjour, J’ai trois ordinateurs à la maison qui tournent sous Ubuntu 16.04 ; j’ai installé sur un de ces ordinateurs Ubuntu 20.04 et j’ai voulu ajouter l’imprimante réseau (sur ma freebox en liaison USB) comme c’était auparavant. Je n’y arrive absolument pas alors que cela marche sur les deux autres ordinateurs. Si vous pouviez m’éclairer, je serai ravi et je vous en remercie d’avance.
    Mes amitiés.

      1. Avant de passer à Ubuntu 20.04 sur l’un de mes 3 ordinateurs en réseau, ils tournaient sous ubuntu 16.04 et pour chacun j’allais dans « imprimante » puis choisir une imprimante réseau avec Samba et mon imprimante Canon Pixma IP 4500 était vu, je lançais la configuration et tout se passait vite et bien. J’ai donc suivi la même procédure pour le PC tournant maintenant sous Ubuntu 20.04 et rien n’y fait ; un moment donné, une fentre s’ouvre avec workgroup et mot de passe à renseigner et rien ne marche. J’ai essayé aussi avec « Appsocket/HP… » mais le problème est le même. Si je me mets en direct sur l’imprimant, elle est trouvée tout de suite et je peux imprimer. Je suis un peu perdu !!!

  10. bonjour, j’ai un PC windows10+office365 et divers logiciels (photo,corel,etc), je serais désireux d’utiliser ubuntu et libre office. comment procéder pour récupérer programmes et fichiers ? merci

    1. Bonjour Daniel,

      Les programmes propriétaires sous Windows sont rarement disponibles sous Linux (Ubuntu). Toutefois, il est possible d’en faire tourner certains avec Wine même si l’opération est plutôt réservé aux utilisateurs avancés.

      Si vous voulez continuer de les utiliser, vous avez deux possibilités :
      1/ avoir un Dualboot Windows/Ubuntu. Ainsi votre installation Windows ne sera pas touchée et vous pourrez toujours utiliser vos logiciels et partage l’accès à vos fichiers. La procédure d’installation en DualBoot n’est pas compliquée. Et vous pouvez accéder depuis Ubuntu aux partitions Windows.
      2/ avoir une machine virtuelle Windows (avec par exemple Virtualbox) que vous pourrez lancer sous Linux. Il vous faudra alors installer sur cette machine virtuelle les logiciels que vous souhaitez utiliser.

      Concernant vos fichiers et documents, si sous Windows, vous les stockez dans les dossiers utilisateurs par défaut (C:\Users\votre_user\Documents etc), copiez ces dossiers sur un autre disque.
      S’ils sont sur un autre emplacement de C:\, pareil, copiez les vers un autre disque.
      Et s’ils sont déjà sur un autre disque, alors pas de soucis si vous formatez votre disque Windows pour installer Ubuntu.

      Cordialement

  11. Bonjour, moi sur la nouvelle version 20.04 sous xubuntu, je m’aperçois que gdebi ne fonctionne plus comme avant.

    Je croyais xfce stable, pour certain d’autre logiciel il fonctionne mieux que sur les versions 18.04.

    Si vous lisais ses commentaires développeur pouvez-vous corriger ses bugs avant de passer sur autre chose.
    Même si l’informatique évolue, avoir de la stabilité c’est mieux pour les logiciels.
    Je reconnais que cela représente beaucoup de travail cher développeur.
    A l’occasion salutation à tous et vive Linux .

    1. Bonjour Jérémie,

      Si vous avez des bugs, signalez les sur le site dédié à cela pour Ubuntu : https://bugs.launchpad.net/ubuntu ou sur le launchpad de la variante utilisée ou directement sur celui de gdebi.

      Numetopia est totalement indépendant de Ubuntu ou autres logiciels/Distribution/systèmes présentés sur le site !

      Sinon, je recommande généralement de patienter quelques semaines/mois avant de passer à une nouvelle version LTS pour justement éviter les bugs de jeunesses…

      Puis, concernant Gdebi, j’ai constaté aussi plusieurs problèmes dans les dernières versions de Ubuntu, mais moins quand on l’utilise en ligne de commande

      Cordialement

  12. Moi je viens de d’installer le 20.4
    Mais je ne sais pas pourquoi quand j’installe Texstudio par toutes les manières possible,ça signale que ça manque un package de macro. Et de plus le gestionnaire de synoptic et d’autre se ferment de façons innatendue

  13. Bonjour,
    merci pour la clarté de la présentation du nouveau LTS.
    Est-ce que l’hibernation va être installée d’office ou bien va-t-il falloir encore galérer pour l’installer a posteriori?
    J’utilise aussi le « menu classique de l’indicateur » que je trouve très pratique, sera-t-il encore disponible?
    Cordialement.
    Serge

  14. Bonjour,

    Ce site est très clair, bravo.

    Je recherche comment lancer mon script de sauvegarde avant la fermeture du poste lorsque j’éteins l’ordinateur.
    Avez-vous une idée ?

    Cordialement

  15. je ne sais pas quels sont les versions de tar.la version de tar sur Ubuntu 19.04 (standard) est très « barbante  » avec l’option « C » .alors que sur la version « studio » cette option est inutile. Si les dépendances sont les mêmes je pourrais copier la version studio sur la standard.
    Je préfère l’acheter : moins cher que windaube et bien plus complète !!

    1. Il n’y a rien à acheter, Ubuntu est gratuite. C’est un logiciel libre.
      Que voulez vous dire par dans la version studio elle n’est pas utile ? Parce que si vous voulez créer une archive tar en ligne de commande il faut spécifier l’argument -c quelque soit la version de Ubuntu…
      Ubuntu Studio est une variante Ubuntu officielle optimisée pour le multimédia, la création,… Les logiciels préinstallés dans cette variante sont disponibles sur les dépôts et peuvent être installé sur toutes versions de Ubuntu.
      Petit conseil, si vous êtes encore sur Ubuntu 19.04, mettez à niveau car cette version n’est plus supportée…

      Cordialement

  16. où peut on acheter Ubuntu 20.4 ( focal fossa )je désire Ubuntu « normal » avec gnome et Ubuntu Studio .?
    Quelle version de « tar » existe sur Ubuntu « normal » ?

    1. Bonjour Eric,

      Vous pouvez télécharger gratuitement Ubuntu sur leur site officiel (lien dans l’article). Pas besoins de l’acheter. Actuellement Ubuntu 20.04 est toujours en BETA, la version finale doit sortir le 23 Avril.
      Ubuntu Studio utilise comme environnement XFCE qui est plus léger que GNOME.
      La version de TAR dans Ubuntu 20.04 est 1.30.

      Cordialement