Comment installer Wine 5.0 sur Ubuntu ou Linux Mint

L’installation de Wine 5.0 depuis les dépôts de WineHQ sur Ubuntu 18.04 ou Linux Mint 19.x peut renvoyer une erreur de dépendance. Aussi, voici comment faire pour installer Wine 5.0 ou plus récent sur Ubuntu ou Linux Mint.

Introduction

Depuis Wine 4.5, le paquet Wine (version stable, développement ou expérimental) nécessite pour son installation la librairie libaudio0. Cette librairie est contenu dans le paquet FAudio. Or, ce paquet n’est pas présent sur les dépôts de Ubuntu avant Ubuntu 19.10.

De plus, n’étant pas développée par le projet Wine, les dépôts de WineHQ ne la fournissent pas non plus… Sauf que, sans cette librairie, lors de l’installation de Wine 5.0 ou supérieure sur Ubuntu 18.04 et Linux Mint 19.x depuis les dépôts de WineHQ, echoue.

ubuntu - erreur installation wine 5

Mais, heureusement, il y a une solution comme nous allons le voir.

Installation de Wine 5.0 ou plus récent sur Ubuntu ou Linux Mint

L’installation se fera en ligne de commande. Et avant d’aller plus loin, si votre système est 64 bits, commencez par activer l’architecture 32 bits avec la commande :

sudo dpkg --add-architecture i386

Ajout du dépôt WineHQ

Commençons par ajouter la clé du dépôt :

wget -nc https://dl.winehq.org/wine-builds/winehq.key && sudo apt-key add winehq.key

Alors, sur Ubuntu, peu importe la version, l’ajout de ce dépôt peut se faire avec la commande :

sudo apt-add-repository "deb https://dl.winehq.org/wine-builds/ubuntu/ $(lsb_release -sc) main"

Sinon, en fonction de la version de Ubuntu, ou sur Linux Mint faites :

  • Pour Ubuntu 16.04 et Linux Mint 18.x :
sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ xenial main'
  • Pour Ubuntu 18.04 et Linux Mint 19.x :
sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'
  • et pour Ubuntu 20.04 et Linux Mint 20.x :
sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ focal main'

Ajout du dépôt pour avoir libaudio0

Uniquement pour Ubuntu 18.04 et Linux Mint 19.x. Sous Ubuntu 16.04 et Linux Mint 18.x, pas besoins d’ajouter de dépôt supplémentaire.

Par le dépôt OBS de Wine

Libaudio0 est disponible sur le dépôt OBS de Wine qui peuvent être ajouté ainsi :

Téléchagez la clé du dépôt Release.key.

Puis pour l’ajouter, depuis le dossier où elle se trouve, faites :

sudo apt-key add Release.key

ou plus simplement, faites :

wget -O- -q https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/Release.key | sudo apt-key add -

Puis ajoutez le dépôt pour Ubuntu 18.04 ou Linux Mint 19.x

sudo apt-add-repository 'deb https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/ ./'

Par un PPA

Une autre solution est de passer par un PPA (non officiel). Pour ajouter ce PPA, faites :

sudo add-apt-repository ppa:cybermax-dexter/sdl2-backport

Installation de Wine 5.0 sur Ubuntu ou Linux Mint

D’abord, mettez à jour la liste de paquets :

sudo apt update

puis, pour installer la version stable de wine, faites :

sudo apt install --install-recommends winehq-stable

ubuntu - installation wine 5

ou si vous voulez installer la version en cour de développement :

sudo apt install --install-recommends winehq-devel

et pour la version expérimentale :

sudo apt install --install-recommends winehq-staging

Enfin, vous pouvez vérifier le numéro de version installé de Wine avec :

wine --version

vérification version wine

Pour aller plus loin

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

13 Commentaires

  1. idem, j’ai essayé toutes les méthodes disponibles et pas une seule ne permet d’installer Wine, il y a toujours une ou l’autre dépendance non satisfaite et « impossible de corriger… mode garder en l’état » ou wine non-trouvé ; et si j’installe wine j’obtiens « wine32 is missing » et encore « wine32:i386 : Dépend: libwine:i386 (= 5.0-3ubuntu1) mais ne sera pas installé »
    Wine a pour ainsi dire de tout temps été pénible à installer mais on pouvait encore, là c’est impossible :s Je vais voir sur irc Mint s’ils ont une solution…

  2. Bonjour

    J’ai un problème avec l’installation, il est dit :

    « Les paquets suivants contiennent des dépendances non satisfaites :
    winehq-devel : Dépend: wine-devel (= 5.17~xenial)
    E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l’état ».  »

    Après la commande « sudo apt install –install-recommends winehq-devel »

    Je ne sais pas quoi faire d’autre car j’ai déjà essayé les autres moyens de téléchargement mais ils affichent la même erreur :/

    1. Bonjour David,

      Avec-vous des erreurs lorsque vous exécutez la commande ?

      sudo apt update && sudo apt updgrade

      Avez-vous déjà une version de Wine installée depuis les dépôts Ubuntu auparavant ?

      Si oui, désinstallez la complétement avec la commande :

      sudo apt autoremove --purge wine*

      Puis, purgez le cache apt avec la commande :

      sudo apt clean

      Remettez votre cache à jour :

      sudo apt update

      Vérifiez que le dépôt WineHQ est bien présent dans la liste de dépôts. Et re-testez l’installation.

      Cordialement