Comment installer LibreOffice 6 sur Debian 9 Stretch

Par défaut, Debian 9 propose LibreOffice 5.2.x. Aussi, voici 3 méthodes pour installer LibreOffice 6 (et versions suivantes) sur Debian 9.

Méthode 1 : Installer LibreOffice 6.x sur Debian 9 depuis les installeurs téléchargés

Cette méthode permet d’avoir LibreOffice 6.2 dans Debian 9 et si vous le voulez, de garder la version déjà installée. C’est la méthode préconisée par les développeurs. Par contre, elle présente l’inconvénient de ne pas permettre la mise à jour automatique de LibreOffice lors de la sortie de nouvelle version.

Installation de LibreOffice 6.x en français

Rendez-vous sur la page de téléchargement de LibreOffice branche Évolution pour y télécharger :

• l’installeur au format DEB : LibreOffice_6.X.X_Linux_x86-64_deb.tar.gz
• et le fichier proposé par le lien Interface Utilisateur traduite : LibreOffice_6.X.X_Linux_x86-64_deb_langpack_fr.tar.gz. Ainsi, vous pourrez passer l’interface graphique en français.

Décompressez l’archive LibreOffice_6.X.X_Linux_x86-64_deb.tar.gz. Pour cela, vous pouvez avec un clic droit de la souris sur le fichier faire Extraire ici.

Debian 9 - Extraire les Installeurs de LibreOffice

Ou utilisez une ligne de commande de type :

nom_de_l_archive.tar.gz est à remplacer par le nom de votre archive.

Alors, ouvrez une fenêtre de terminal et rendez-vous dans le dossier LibreOffice_6.X.X_Linux_x86-64_deb/DEBS :

tips Pas besoins de tout écrire, vous pouvez commencez à écrire le chemin puis utilisez la touche Tab ↹ pour compléter la ligne de commande.

chemin_vers_le_dossier : à remplacer pour votre chemin

LibreOffice_6.X.X_Linux_x86-64_deb : X à remplacer par le numéro de version correspondant

Ou, vous pouvez aussi y aller via le navigateur de fichier et dans ce dossier, sans sélectionner de fichiers, faire un clic avec le bouton droit de la souris et choisir Ouvrir dans un terminal.

Debian 9 - Ouvrir un terminal dans le dossier

Puis, dans le terminal, entrez la commande suivante pour lancer l’installation de LibreOffice

Alors, pour traduire l’interface, décompressez l’archive LibreOffice_6.x.x_Linux_x86-64_deb_langpack_fr.tar.gz. Et dans le répertoire chemin_vers_le_dossier/LibreOffice_6.X.X_Linux_x86-64_deb_langpack_fr/DEBS, exécutez la même commande :

Installation des fichiers d’aide pour l’utilisation hors ligne en français

Téléchargez et décompressez le fichier pointé avec le lien Aide pour l’utilisation hors ligne : LibreOffice_6.0.x_Linux_x86-64_deb_helppack_fr.tar.gz.

Puis dans chemin_vers_le_dossier/ LibreOffice_6.X.X_Linux_x86-64_deb_helppack_fr/DEBS, exécutez à nouveau la commande

Méthode 2 : Installer LibreOffice 6.x sur Debian 9 depuis le format Flatpak

C’est la méthode la plus simple pour installer LibreOffice 6.x sur Debian 9. Elle ne touche pas à la version déjà installée. Donc, vous pouvez faire cohabiter les deux. C’est la méthode que j’utilise.

Aussi, d’un point de vue générale, je recommande l’utilisation du format Flatpak pour installer les versions récentes de vos logiciels car il présente plusieurs avantages :

  • facilité d’installation et d’utilisation
  • la sécurité. En effet, une application Flatpak s’exécute dans une sandbox.
  • mises à jour facile et avec GNOME 3.30 (qui viendra avec Debian 10 Buster) intégrées aux autres mises à jour automatique
  • un large éventail d’applications

Mais l’utilisation du format Flatpak nécessite au préalable l’installation de la prise en charge du format Flatpak dans Debian.

Installation de la prise en charge du format Flatpak dans Debian

Rien de plus simple ! Il suffit de suivre ce tutoriel 😉 :

Installation et utilisation de Flatpak sous Debian

Installation de LibreOffice 6.x au format Flatpak

Puis, pour installer la dernière version de LibreOffice, entrez la commande suivante dans un termail :

Et, pour le mettre à jour, vous n’aurez qu’à faire :

Méthode 3 : Installer LibreOffice 6.x sur Debian 9 depuis les dépôts Backports

Cette méthode remplace la version de LibreOffice installée. Mais, elle permet de garder à jour le logiciel grâce au Gestionnaire de mises à jour.

Toutefois, la version de LibreOffice présente dans les dépôts Backport n’est pas celle de la branche Évolution, mais celle de la branche Stable.

Qu’est que les dépots Backports ou de rétroportages

Les dépôts Backports proposent des paquets rétro-portés depuis la version testing de Debian et dans certains cas depuis la version unstable pour la version courante de Debian. Ainsi, cela permet d’avoir des versions plus récentes pour les logiciels proposés de base.

Puis, lors des mises à jour, par exemple avec sudo apt upgrade, uniquement les paquets installés depuis les dépôts Backports seront mis à jour depuis ces derniers. Les autres paquets garderont leur canal de mises à jour habituel, même s’il existe une version plus récente rétro-portée.

Pour plus d’informations sur les Backports, consultez :

Toutefois, leur utilisation n’est pas sans risque. En effet, les paquets rétro-portés sont moins bien testés et peuvent donc provoquer des bugs ou de l’instabilité avec le reste du système…

Aussi, si vous êtes débutants, je ne vous recommande pas leur utilisation. Choisissez une autre méthode, plus simple et moins risquée… Mais si vous y tenez à appliquer cette méthode, prenez vos précautions et faites préalable une sauvegarde de votre système par exemple avec Timeshift. Ainsi, vous pourrez revenir facilement en arrière en cas de problème. Et surtout n’installez pas n’importe quel paquet depuis ces dépôts…

Ajouter les dépôts Backports à vos sources de paquets

Pour ajouter les dépôts Backport à vos sources de paquets, ouvrez le fichier /etc/apt/sources.list.d/sources.list avec des droits administrateurs pour pouvoir l’éditer. Puis ajoutez à la fin la ligne suivante : deb http://ftp.debian.org/debian stretch-backports main

Vous pouvez remplacer http://ftp.debian.org/debian par un miroir local dont vous retrouverez la liste ici. Vous pouvez aussi ajouter contrib et non-free si vous voulez par la suite installer des paquets provenant de ces sections. Pour plus d’information sur le sujet, consultez dans la documentation officiel de Debian § 2.1.4. Bases concernant l’archive.

tips Pour éditer le fichier sources.list, vous pouvez entrer la commande suivante dans un terminal :

Debian 9 - fichier sources.list avec backports

Debian 9 – fichier sources.list avec backports

Une fois cela fait, mettez à jour la liste de paquets disponibles sur les dépôts :

Installer LibreOffice 6.x depuis les Backports

Puis installez LibreOffice, la traduction de son interface en français et les fichiers d’aides avec la commande suivante :

-t stretch-backports : permet de préciser que l’installation des paquets suivants (et uniquement eux) se fera depuis les dépôts Backports.

libreoffice-l10n-fr : paquet pour installer la traduction de l’interface en français (facultatif si vous voulez garder la langue de Shakespeare plutôt que celle de Molière).

libreoffice-help-fr : paquet pour installer l’aide consultable hors ligne en français (facultatif).

Autres méthodes possibles pour installer LibreOffice 6.0 sur Debian 9

D’autres moyens existent pour installer les versions récentes de LibreOffice comme l’utilisation du format AppImages.

Désinstaller LibreOffice de votre Debian

Pour désinstaller complètement LibreOffice, utilisez la ligne de commande suivante :

ou si vous voulez aussi désinstaller les fichiers de configuration :

Pour aller plus loin

Vous pouvez consulter les pages suivantes du wiki Debian au sujet des dépôts Backports et des différentes sections d’archives :

Et vous pouvez consulter le wiki de The Document fondation (les développeurs du LibreOffice) : https://wiki.documentfoundation.org/Main_Page/fr et la page dédiée à l’installation du logiciel sur Linux https://wiki.documentfoundation.org/Documentation/Install/Linux/fr.

13 Comments

  1. lulu

    Bonjour,
    J’ai une Debian 9 (stretch), ma version installé de LibreOffice est toujours en 5.3.6.1 (alors que la version stable actuelle est la 6.0.6), pourquoi ne se met-elle pas à jour avec l’outil de mise à jour avec l’outil de mise à jour de paquets ??

    merci d’avance

    Reply
    1. Le Tux Masqué (Post author)

      Bonjour Lulu,

      La version que vous avez n’est-elle pas plutôt la 5.2.x.x ?
      La politique de Debian concernant les logiciels présents sur ses dépôts est de rester sur les versions validées lors de la sortie de la distribution. Ainsi pour Debian 9 Stretch, lors de sa sortie, c’était la version 5.2. Par contre cette version est toujours mise à jour avec les versions de maintenance (5.2.6 ou 5.2.7 etc.) pour corriger les bugs et problèmes de sécurité.
      Cette politique a pour un but de garantir la stabilité de la distribution (ce qui fait d’ailleurs sa réputation…), mais certes au détriment de certaines nouveautés logicielles.
      Qui dit changement de version majeure dit aussi peut-être des mises à jour de certaines dépendances et donc peut-être des problèmes de compatibilité avec d’autres composants du système…
      Donc pour avoir la dernière version de LibreOffice sur Debian, soit il faut attendre la sortie de la prochaine version de la distribution, soit appliquer l’une des méthodes citées ci-dessus 🙂

      Cordialement

    2. lulu

      Merci.
      La 5.2 n’est pas maintenue ( https://fr.wikipedia.org/wiki/LibreOffice … j’ai pas trouvé de récap sur le site officiel), je devrais meme etre en 5.4.7 pour avoir les dernières mises à jour de sécurité) ?!

    3. lulu
    4. Le Tux Masqué (Post author)

      Bonjour Lulu,

      Comme je le disais dans ma précédente réponse, Debian, une fois la distribution sortie et passée en branche « stable », les paquets qu’elle embarque sont figés et uniquement mis à jour pour des raisons de maintenance et de correction de problème de sécurité (https://fr.wikipedia.org/wiki/Debian#Sections_de_paquets_logiciels). Mais, pour profiter des versions plus récentes, il y a plusieurs possibilités :

      A l’heure où j’écris ce commentaire, au niveau des dépôt Debian, la version LibreOffice proposée est :

      Et au niveau de LibreOffice (c’est tout récent et la page Wikipédia n’est pas encore à jour…) :

      Si vous avez une version 5.3.6.1 sur Debian 9, c’est que vous avez du l’installer manuellement au moment de sa sortie. Et donc, si vous voulez avoir la version 5.4.7, il faudra là aussi l’installer manuellement.

      Sinon appliquez une des méthodes citées ci-dessus pour installer la dernière version de LibreOffice.

    5. lulu

      Merci.

      La 5.2.7 ça m’irait aussi (je préfère ne pas avoir à faire de mise à jour manuelles), je ne sais pas pourquoi je suis en 5.3.6.1 .
      Un habitué m’avait installé stretch, après quoi il y avait 2 version de LO (surement un reste de Wheezy) et normalement on n’avait gardé que la version censée suivre les mises à jour, mais il y a du avoir erreur à ce moment là.

    6. Le Tux Masqué (Post author)

      Pour nettoyer les différentes versions installées, vous pouvez faire dans un terminal :

      Puis pour réinstaller la version des dépôts Debian, faites :

      Pour passer LibreOffice en français :

      Pour l’intégrer à Mate ou XFCE :

      pour GNOME :

      pour KDE :

      Et voilà, vous devriez avoir ainsi la version disponible sur les dépôts Debian.

    7. lulu

      (réponse au message du 12 septembre 2018 at 15 h 08 min, qui n’a pas de lien reply)

      Merci beaucoup, j’osais pas poser la question car ça devenait hors sujet 🙂

      Je suppose qu’on peut aussi l’intégrer avec LXDE avec la commande
      sudo apt install libreoffice-lxde

      ?

    8. Le Tux Masqué (Post author)

      Non, LXDE est aussi basé sur gtk, donc ça sera :

      sudo apt install libreoffice-gtk

  2. Gael

    Merci beaucoup, j’avais besoin de la version 6 de LibreOffice et ma distrib LMDE 3 était livrée avec la 5.

    J’ai choisi la méthode avec les dépôts backports, peu risqué pour ce cas précis.

    Reply
    1. Le Tux Masqué (Post author)

      Bonjour Gael,

      Merci pour votre commentaire.
      Si d’autre se posait la question, avec LMDE 3 (basée sur Debian 9 mais avec une couche Linux Mint), il y a une autre méthode qui consiste à installer LibreOffice depuis le format Flatpak (qui correspond toujours à la dernière version de la banche Évolution de LibreOffice).
      LMDE 3 intègre directement le format flatpak sans à avoir à l’installer. La recherche dans le flathub (dépôt pour les paquets Flatpak) et l’installation des paquets peut se faire via une interface graphique directement depuis le Gestionnaire de Logiciel. Aussi, cerise sur le gâteau, ils sont aussi mis à jour automatiquement :).
      Ainsi pas besoins d’activer les dépôts backport pour ceux qui hésitent à le faire et ont peur de tout casser en touchant à certains fichiers systèmes…

  3. shiddo

    Chers numetopia,

    Je vous remercie au nom d’un utilisateur Debian qui demande de l’aide sur un forum. Grâce à vos conseils sur l’utilisation des backports, son système ne charge plus son interface graphique, et se retrouve avec un bel ecran noir au demarrage, avec pour seule utilisation un terminal TTY. Ca aurait été sympa à vous de faire lumière sur ce que je mentionne en dessous.

    https://wiki.debian.org/fr/Backports

    Les rétroportages sont des paquets recompilés pour la plupart depuis testing et dans quelques cas seulement (par exemple les mises à jour de sécurité) depuis unstable, de telle sorte qu’ils vont marcher sur une distribution Debian stable, si c’est possible, sans nouvelles bibliothèques. Il est recommandé de ne prendre que les rétroportages dont vous avez vraiment besoin et de ne pas utiliser tous les rétroportages disponibles.

    Reply
    1. Le Tux Masqué (Post author)

      Cher shiddo,

      Vous me voyez désolé de votre situation, mais l’article en question n’est pas sur l’utilisation des dépôts Backports de Debian, il concerne exclusivement l’installation de Libreoffice 6 sur Debian 9. Et dans la section Allez plus loin, vous aviez les liens vers l’article du wiki Debian que vous citez. Si vous avez voulu mettre à jour votre Debian entièrement depuis ces dépôts, ce n’est effectivement pas recommandé.
      Toutefois, votre remarque est bonne et l’article sera modifié pour mieux mettre en avant l’article en question et sur les précautions à prendre sur l’utilisation des dépôts backports.

Leave a Comment

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.